[Juniper]basic config

最近有機會接觸到Juniper的設備

設定方式跟Cisco 或 D-link差真多,真的是非常的不習慣

#預設登入
一開始直接用root登入即可

登入後發現跟unix-like OS一模一樣,可以做ls、cd等操作

#進入Operational Mode

% cli

在Operational Mode模式下可以檢視設備的各種狀態
比較常用的例如查看各個port的基本狀態

>show interfaces terse

查詢ARP

>show ethernet-switching table brief

#進入Configuration Mode

> config 
#OR
#edit有點類似cd功能
> edit  
#進入後會在Configuration Mode最上層[edit]

進入Configuration Mode後查看port的設定

show interfaces

如果要顯示port的狀態則需要再加一個run

run show interfaces terse

#設定帳號
帳號的類別分別有:
super-user: 僅次於 root 的最高管理權限
read-only: 只能讀取設定內容不能修改
operator: 僅能清除 Counter 數值
unauthorized: 禁用該帳號

#[edit]
#建立super-user帳號 admin
set system login user admin class super-user 

#設定帳號密碼
set system login user admin authentication plain-text-password

#其他網路設定

#[edit]
#指定 Default Gateway
set routing-options static route 0.0.0.0/0 next-hop 192.168.1.254

#系統設定

#需要進入[edit system]模式
edit system

#這時會進入到[edit system]模式
#[edit system]

#啟動 Telnet 服務
set services telnet
#啟動 SSH 服務
set services ssh
#啟動 Web 服務
set services web-management http             

#設定主機名稱
set host-name switch
#設定 root 管理帳號密碼 (設定之後才能存檔)
set root-authentication plain-text-password
#設定時區
set time-zone Asia/Taipei
#設定 NTP Server
set ntp server 192.168.1.10
#設定 DNS Server
set name-server 192.168.1.10

#存檔指令

#儲存設定
commit

#在儲存設定以前先檢查相關設定是否有語法上的錯誤
commit check

#儲存設定後若未在指定時間 (預設為 10 分鐘) 內執行第二次 commit 進行確認,否則就回到上一個設定值 (可以防止遠端手誤鎖到自己)
commit confirmed

#可於指定時間自動執行 commit,例如 commit at 20:00:00
commit at time

#可幫此次的commit加上註解
commit comment "Changed Default Gateway IP Address"

#儲存設定後離開 Config Mode
commit and-quit

#rollback 用法

#[edit]
#回到running config,也就是說還沒commit的設定全部都會消失
rollback 0

#回到上一次commit設定
rollback 1

#切vlan

#[edit]
#建立vlan
#設定方式:set vlans <vlan-name> vlan-id <vlan-id>
set vlans vlan224 vlan-id 224

#將interface定義到vlan裡
#設定方式:set interfaces <interface_name> unit 0 family ethernet-switching vlan members <vlan_name>
set interfaces ge-0/0/1 unit 0 family ethernet-switching vlan members vlan224

#設定管理IP

#[edit]
#在vlan設定管理IP 建議unit數字可以跟vlan id一樣
set interfaces vlan unit 224 family inet address 192.168.224.222/24 primary
set interfaces vlan unit 224 family inet address 120.119.112.180/24 
#設定vlan
set vlans vlan224 vlan-id 224
#將vlan224設成L3
edit vlans vlan224
#[edit vlans vlans224]
set l3-interface vlan.224

#將設定檔以指令的方式顯示

#[edit]
show | display set

#大量assign vlan到interface

#[edit]
#建立一個interface,裡面include了0-23 port(interface-name可以自行設定,就是interface的名稱)
set interfaces interface-range <interface-name> member-range ge-0/0/0 to ge-0/0/23

#assign vlan
set interfaces interface-range <group-name> unit 0 family ethernet-switching vlan members <vlan-name>

#關機

>request system halt

[jQuery]cookie用法

[Juniper]忘記root密碼